Tuesday, October 12, 2010

Google Apps Outgoing Mail Server Not Authenticating

I wrote this post to help anyone who has had a problem with accessing their Google Apps outgoing mail server. Unfortunately this post turned into a bit of an outlet for the problems I had with figuring this problem out so if you want to skip to the answer then jump down to the Short Answer section

The Back Story

I use regular Gmail but send my outgoing mail through my Google Apps outgoing mail server. The reason for this is I like to have my Emails appear to have come from my custom domain Email address and I like to use the regular non-Google-Apps Gmail service as it allows me to use a single sign in to access almost all of Google's services.

Recently the people at Google have decided to allow Google Apps users to use their custom domain addresses to sign in to more Google services such as Blogger and Picasa. The roll out of this new feature is coming this fall and a few Google Apps users may have access to this feature now. I happened to be one of those users and when I logged into my Google Apps account I was asked if I wanted to activate this new feature.

I am a bit of a sucker to new services so I activated the new service and logged out. This was not really a big deal for me as I mainly use my regular @gmail account for signing into all the Google services. I thought all was running smoothly until today when I talked to someone who said they had not received my email. I didn't think much of it until I logged back into my Google Apps account to check the Spam folder (which I do from time to time to check if any email got in there by mistake). It was in my Google Apps Spam folder that I discovered a bunch of  Mail Delivery Subsystem - Delivery Status Notification (Failure) Email messages that had been wrongly marked as spam by Google, which prevented me from knowing there was anything wrong with my Email.

After some troubleshooting I soon discovered that my Send Mail As feature in Gmail that used my custom domain email address for sending out emails was not able to access the outgoing Google Apps server. The solution turned out to be very simple.

The problem was that my Google Apps Gmail service required some real human input in order to activate a new Gmail account or choose some other options, either way a selection of some sort was required to access the account. This only occurred when I tried to login to my Google Apps Gmail service through the regular Gmail login page and not my Google Apps login page. Once I made the required selections and activated the Gmail account I could access the account regularly and my main Gmail account's Send Mail As feature worked once again.

The Short Answer

If you run into this problem of your Outgoing Gmail or Google Apps Gmail SMTP Outgoing server not authenticating or seemingly not working for no apparent reason and you have checked and double checked your server and password settings then try logging directly into your Gmail or Google Apps Gmail account and seeing if any human interaction is required. I have read that some people have had to enter a CAPTCHA after logging into their Gmail and or Google Apps Gmail accounts and this might cause the same problem.

Any comments are always greatly appreciated.